ABOUT ME

-

Today
-
Yesterday
-
Total
-
  • 공공데이터를 사용하려면 자바버전을 강제 하는군요.
    JAVA 2014. 9. 23. 10:59
    반응형

    공공데이터 사이트(www.data.go.kr) 에서 제공하는 데이터를 사용하기 위해선 키를 생성해야 합니다. 키 생성을 위한 툴을 사이트에서 제공해주고 있습니다. 이 키 생성 툴은 자바로 만들어진 툴로, exe 형식의 실행파일로 되어 있습니다. 

    받아서 키를 생성하려고 하니, 아래 화면과 같은 메세지가 뜹니다.



    JRE 를 하나 더 설치하면 됩니다. 하지만, JAVA8 이 나온 시점에 아직도 1.6.4 까지만 사용이 가능하다니 너무 하네요.

    오라클에서도 보안 문제로 인하여 계속 자바 업데이트를 하고 있습니다. 1.6 버전은 업데이트 45까지 나와 있구요. 키만 생성하고 JRE 를 삭제하면 되겠지만, 근본적으로 OLD 버전만 지원한다는건 문제가 있습니다.

    공무원을 탓하고 싶지 않습니다. 그들은 개발자가 아니라 일반인과 똑 같을테니까요. 하지만, 이걸 외주 받아 개발한 회사는 욕좀 먹어야 하지 않을까요?

    자바 8 까지는 바라지도 않습니다. 최소한 현재 개발자들이 가장 많이 사용하는 자바 7은 지원해줬으면 합니다. 그리고 마이너 패치 버전은 왜 제한을 거는건지 모르겠네요. 아무 생각 없이 막은거다라고 생각할 수 밖에 없습니다.

    마지막으로 사이트에 바라는 점은 FAQ 에 이러한 내용을 작성해 주세요. 최소한 Fucking Asked Questions 는 있어야 하는게 기본입니다.


    반응형

    댓글

Designed by Tistory.